diff configure.in @ 3160:4696773a14b1

[project @ 1998-03-02 06:18:12 by jwe]
author jwe
date Mon, 02 Mar 1998 06:23:19 +0000
parents 974e596662f9
children 2837d1701fd9
line wrap: on
line diff
--- a/configure.in	Tue Feb 24 06:32:31 1998 +0000
+++ b/configure.in	Mon Mar 02 06:23:19 1998 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.299 $)
+AC_REVISION($Revision: 1.300 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -256,15 +256,15 @@
       AC_MSG_RESULT([adding -mieee-fp to XTRA_CXXFLAGS])])
   ;;
   alpha*-*-*)
-    OCTAVE_CC_FLAG(-mieee, [
-      ieee_fp_flag=-mieee
-      XTRA_CFLAGS="$XTRA_CFLAGS -mieee"
-      AC_MSG_RESULT([adding -mieee to XTRA_CFLAGS])])
+    OCTAVE_CC_FLAG(-mieee-with-inexact, [
+      ieee_fp_flag=-mieee-with-inexact
+      XTRA_CFLAGS="$XTRA_CFLAGS -mieee-with-inexact"
+      AC_MSG_RESULT([adding -mieee-with-inexact to XTRA_CFLAGS])])
 
-    OCTAVE_CXX_FLAG(-mieee, [
-      ieee_fp_flag=-mieee
-      XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee"
-      AC_MSG_RESULT([adding -mieee to XTRA_CXXFLAGS])])
+    OCTAVE_CXX_FLAG(-mieee-with-inexact, [
+      ieee_fp_flag=-mieee-with-inexact
+      XTRA_CXXFLAGS="$XTRA_CXXFLAGS -mieee-with-inexact"
+      AC_MSG_RESULT([adding -mieee-with-inexact to XTRA_CXXFLAGS])])
   ;;
 esac
 
@@ -373,7 +373,8 @@
       fi
       case "$canonical_host_type" in
         alpha*-*-*)
-          if test "$f77_is_g77" = yes || test -z "$ieee_fp_flag" ; then
+          if test "$octave_cv_f77_is_g77" = yes \
+	      || test -z "$ieee_fp_flag" ; then
             true
 	  else
 	    FFLAGS="-fpe1 $FFLAGS"
@@ -566,6 +567,11 @@
     SONAME_FLAGS='-Xlinker -soname -Xlinker $@'
     RLD_FLAG='-Xlinker -rpath -Xlinker $(libdir)'
   ;;
+changequote(,)dnl
+  i[3456]86-*-sco3.2v5*)
+changequote([,])dnl
+    SH_LDFLAGS=-G
+  ;;
   rs6000-ibm-aix* | powerpc-ibm-aix*)
     CPICFLAG=
     CXXPICFLAG=
@@ -573,7 +579,7 @@
     DLFCN_DIR=dlfcn
   ;;
   hppa*-hp-hpux*)
-    if test "$f77_is_g77" = yes; then
+    if test "$octave_cv_f77_is_g77" = yes; then
       FPICFLAG=-fPIC
     else
       FPICFLAG=+Z
@@ -589,7 +595,7 @@
     RLD_FLAG='-L$(libdir)'
   ;;
   sparc-sun-sunos4*)
-    if test "$f77_is_g77" = yes; then
+    if test "$octave_cv_f77_is_g77" = yes; then
       FPICFLAG=-fPIC
     else
       FPICFLAG=-PIC
@@ -599,7 +605,7 @@
     RLD_FLAG='-L$(libdir)'
   ;;
   sparc-sun-solaris2*)
-    if test "$f77_is_g77" = yes; then
+    if test "$octave_cv_f77_is_g77" = yes; then
       FPICFLAG=-fPIC
     else
       FPICFLAG=-PIC
@@ -704,8 +710,8 @@
 GLOB_DIR=glob
 LIBGLOB='$(TOPDIR)/glob/libglob.$(LIBEXT)'
 GLOB_INCFLAGS='-I$(top_srcdir)/glob -I$(TOPDIR)/glob'
-if test "$ac_cv_header_fnmatch.h" = yes \
-  && test "$ac_cv_header_glob.h" = yes; then
+if test "$ac_cv_header_fnmatch_h" = yes \
+  && test "$ac_cv_header_glob_h" = yes; then
   GLOB_DIR=
   AC_CHECK_LIB(glob, glob)
   AC_CHECK_FUNCS(fnmatch glob)
@@ -742,6 +748,11 @@
       DLFCN_INCFLAGS='-I$(top_srcdir)/dlfcn -I$(TOPDIR)/dlfcn'
       WITH_DL=true
     ;;
+changequote(,)dnl
+    i[3456]86-*-sco3.2v5*)
+changequote([,])dnl
+      WITH_DL=true
+    ;;
     *)
       AC_CHECK_LIB(dl, dlopen)
       AC_CHECK_FUNCS(dlopen dlsym dlerror dlclose)
@@ -1113,7 +1124,8 @@
 
 ### Do the substitutions in all the Makefiles.
 
-AC_OUTPUT(Makefile octMakefile Makeconf test/Makefile dlfcn/Makefile
+AC_OUTPUT(Makefile octMakefile Makeconf install-octave
+  test/Makefile dlfcn/Makefile
   doc/Makefile doc/faq/Makefile doc/interpreter/Makefile
   doc/liboctave/Makefile doc/refcard/Makefile emacs/Makefile
   examples/Makefile liboctave/Makefile src/Makefile