diff configure.in @ 4816:4908c82cd1a1

[project @ 2004-03-04 18:13:46 by jwe]
author jwe
date Thu, 04 Mar 2004 18:13:46 +0000
parents 5997796932b1
children 7b4e76100964
line wrap: on
line diff
--- a/configure.in	Thu Mar 04 00:14:44 2004 +0000
+++ b/configure.in	Thu Mar 04 18:13:46 2004 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.448 $)
+AC_REVISION($Revision: 1.449 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -94,13 +94,6 @@
   [if test "$withval" = no; then use_f2c=false; else use_f2c=true; fi],
   use_f2c=false)
 
-### Allow the user to force us to use g77.
-
-AC_ARG_WITH(g77,
-  [  --with-g77              use g77 to compile Fortran subroutines],
-  [if test "$withval" = no; then use_g77=false; else use_g77=true; fi],
-  use_g77=false)
-
 ### Allow the user to force us to use f77.
 
 AC_ARG_WITH(f77,
@@ -111,21 +104,11 @@
 ### Make sure only one of the above options for Fortran compilers was
 ### specified (multiple "no" or --without-FOO options are ok).
 
-OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(f77, g77,
-  [warn_f77_and_g77="--with-f77 and --with-g77 both specified!  Using g77..."
-  AC_MSG_WARN($warn_f77_and_g77)
-  use_g77=false])
-
 OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(f77, f2c,
   [warn_f2c_and_f77="--with-f2c and --with-f77 both specified!  Using f77..."
   AC_MSG_WARN($warn_f2c_and_f77)
   use_f2c=false])
 
-OCTAVE_CHECK_EXCLUSIVE_WITH_OPTIONS(g77, f2c,
-  [warn_f2c_and_g77="--with-f2c and --with-g77 both specified!  Using g77..."
-  AC_MSG_WARN($warn_f2c_and_g77)
-  use_f2c=false])
-
 dnl ### Allow the user disable support for plplot.
 dnl 
 dnl # USE_PLPLOT=true
@@ -455,11 +438,10 @@
 ### try to find one using any one of several common Un*x Fortran
 ### compiler names using the AC_PROG_F77 macro.
 ###
-### The configure options --with-f77, --with-g77, or --with-f2c
-### force f77, g77 or f2c to be used.  It is also possible to use
+### The configure options --with-f77 or --with-f2c
+### force f77 or f2c to be used.  It is also possible to use
 ### these options to specify the name of the compiler.  For example,
-### `--with-g77=/opt/gnu/bin/f77' says that we are using g77 but it is
-### installed as /opt/gnu/bin/f77.
+### `--with-f77=g77' says that we are using g77 as the Fortran compiler.
 
 if $use_f77; then
   if test "$with_f77" = yes; then
@@ -468,13 +450,6 @@
     F77="$with_f77"
   fi
   AC_MSG_RESULT([defining F77 to be $F77])
-elif $use_g77; then
-  if test "$with_g77" = yes; then
-    F77=g77
-  else
-    F77="$with_g77"
-  fi
-  AC_MSG_RESULT([defining F77 to be $F77])
 elif $use_f2c; then
   F77=
   if test "$with_f2c" = yes; then
@@ -1531,21 +1506,11 @@
   fi
 fi
 
-if test -n "$warn_f77_and_g77"; then
-  AC_MSG_WARN($warn_f77_and_g77)
-  warn_msg_printed=true
-fi
-
 if test -n "$warn_f2c_and_f77"; then
   AC_MSG_WARN($warn_f2c_and_f77)
   warn_msg_printed=true
 fi
 
-if test -n "$warn_f2c_and_g77"; then
-  AC_MSG_WARN($warn_f2c_and_g77)
-  warn_msg_printed=true
-fi
-
 if test -n "$gxx_only"; then
   AC_MSG_WARN($gxx_only)
   warn_msg_printed=true