diff configure.in @ 9403:4af6e29449c1

[mq]: graphics_text_engine
author Michael Goffioul <michael.goffioul@gmail.com>
date Fri, 26 Jun 2009 21:12:09 +0100
parents 75c502937d2c
children 69d05d1a63b9
line wrap: on
line diff
--- a/configure.in	Fri Jun 26 20:49:41 2009 +0100
+++ b/configure.in	Fri Jun 26 21:12:09 2009 +0100
@@ -687,7 +687,7 @@
   AC_DEFINE(HAVE_OPENGL, 1, [Define if OpenGL is available])
 
 ## ftgl (needs freetype 2)
-  AC_CHECK_FT2([9.0.3],[],
+  AC_CHECK_FT2([9.0.3],[AC_DEFINE(HAVE_FREETYPE, 1, [Define to 1 if you have Freetype library.])],
     [warn_freetype="FreeType library not found. Native renderer will not have on-screen text"])
   if test -z "$warn_freetype"; then
     AC_LANG_PUSH(C++)
@@ -742,6 +742,20 @@
   fi
 fi
 
+# fontconfig library
+
+warn_fontconfig=""
+PKG_PROG_PKG_CONFIG
+if test -z "$warn_freetype"; then
+  PKG_CHECK_MODULES(FONTCONFIG,[fontconfig],[
+    have_fontconfig=yes
+    OPENGL_LIBS="$FONTCONFIG_LIBS $OPENGL_LIBS"
+    XTRA_CXXFLAGS="$XTRA_CXXFLAGS $FONTCONFIG_CFLAGS"
+    AC_DEFINE(HAVE_FONTCONFIG, 1, [Define to 1 if fontconfig is present])],[
+    have_fontconfig=no
+    warn_fontconfig="Fontconfig not found. Native text rendering will use hard-coded font instead."])
+fi
+
 GRAPHICS_LIBS=
 GRAPHICS_CFLAGS=
 
@@ -2436,6 +2450,12 @@
   warn_msg_printed=true
 fi
 
+if test -n "$warn_fontconfig"; then
+  AC_MSG_WARN("$warn_fontconfig")
+  native_graphics=false
+  warn_msg_printed=true
+fi
+
 if test -n "$warn_ftgl"; then
   AC_MSG_WARN("$warn_ftgl")
   native_graphics=false