diff configure.ac @ 15123:4e0ab3b28418

Eliminate duplicate PTHREAD_CFLAGS inclusion in build process. * configure.ac: Add PTHREAD_CFLAGS to CXXFLAGS. * build-aux/common.mx: Remove PTHREAD_CFLAGS from AM_CPFLAGS and AM_CXXFLAGS.
author Rik <rik@octave.org>
date Tue, 07 Aug 2012 09:01:02 -0700
parents c53c28c7c811
children 067699edef86
line wrap: on
line diff
--- a/configure.ac	Tue Aug 07 07:09:54 2012 -0700
+++ b/configure.ac	Tue Aug 07 09:01:02 2012 -0700
@@ -345,6 +345,7 @@
 ## They seem to be required for the OpenGL tests on Debian systems.
 LIBS="$PTHREAD_LIBS $LIBS"
 CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
+CXXFLAGS="$CXXFLAGS $PTHREAD_CFLAGS"
 
 ### When compiling math for x87, problems may arise in some code comparing
 ### floating-point intermediate results.