diff configure.in @ 8850:538184c540a9

Add make target "configfiles" to automatically regenerate configuration files
author Thorsten Meyer <thorsten.meyier@gmx.de>
date Tue, 24 Feb 2009 01:46:37 -0500
parents 8b7e448d989c
children eace5649a8b5
line wrap: on
line diff
--- a/configure.in	Tue Feb 24 00:57:01 2009 -0500
+++ b/configure.in	Tue Feb 24 01:46:37 2009 -0500
@@ -2102,6 +2102,12 @@
 
 ### Do the substitutions in all the Makefiles.
 
+AC_CONFIG_COMMANDS([Makefile], [if test "$ac_srcdir" != "."; then
+  cp $srcdir/Makefile .
+fi])
+
+AC_SUBST(ac_config_files)
+
 AC_CONFIG_FILES([octMakefile Makeconf test/Makefile
   doc/Makefile doc/faq/Makefile doc/interpreter/Makefile
   doc/liboctave/Makefile doc/refcard/Makefile emacs/Makefile
@@ -2116,6 +2122,7 @@
   libcruft/ranlib/Makefile libcruft/slatec-fn/Makefile
   libcruft/slatec-err/Makefile libcruft/villad/Makefile
   libcruft/blas-xtra/Makefile libcruft/lapack-xtra/Makefile])
+
 AC_OUTPUT
 
 ### Print a summary so that important information isn't missed.