diff configure.in @ 8623:53fb843ca498

configure.in (REGEX_LIBS): undo part of previous change
author John W. Eaton <jwe@octave.org>
date Wed, 28 Jan 2009 21:08:53 -0500
parents f1534e248260
children bef8f001032f
line wrap: on
line diff
--- a/configure.in	Wed Jan 28 18:59:44 2009 -0500
+++ b/configure.in	Wed Jan 28 21:08:53 2009 -0500
@@ -457,8 +457,10 @@
 WITH_PCRE="$ac_cv_pcre_h_macros_present"
 
 REGEX_LIBS=
+
 using_pcre=no
 using_regex=no
+
 if test "$WITH_PCRE" = yes; then
   if test "$WITH_PCRE_CONFIG" = yes; then
     REGEX_LIBS=$(pcre-config --libs)
@@ -478,16 +480,16 @@
   AC_MSG_WARN($warn_pcre)
 fi
 
-if test "$using_pcre" = no; then
-  AC_CHECK_FUNCS(regexec, [using_regex=yes], [
-    AC_CHECK_LIB(regex, regexec, [using_regex=yes
-      REGEX_LIBS="-lregex"], [
+AC_CHECK_FUNCS(regexec, [using_regex=yes], [
+  AC_CHECK_LIB(regex, regexec, [using_regex=yes
+    REGEX_LIBS="-lregex $REGEX_LIBS"], [
       warn_regex="regular expression functions not found.  The regular expression matching functions will be disabled."
       AC_MSG_WARN($warn_regex)])])
-  if test "$using_regex" = yes; then
-    AC_DEFINE(HAVE_REGEX, 1, [Define if regex library is available.])
-  fi
+
+if test "$using_regex" = yes; then
+  AC_DEFINE(HAVE_REGEX, 1, [Define if regex library is available.])
 fi
+
 AC_SUBST(REGEX_LIBS)
 
 ### Check for ZLIB library.