diff configure.ac @ 17180:54e251e699bb

Use the new GLPK API (bug #39038). * libinterp/dldfcn/__glpk__.cc: replace old lpx_* function calls by their new equivalents; complete rewrite of the options handling code since the interface for changing them has changed * scripts/optimization/glpk.m: update of the documentation string to reflect the changes in input and output arguments * configure.ac: update test for GLPK library * NEWS: mention the changes in the glpk.m input/output arguments
author Sébastien Villemot <sebastien@debian.org>
date Sat, 03 Aug 2013 15:38:47 +0200
parents 36fd98b9ce48
children bc20614022aa
line wrap: on
line diff
--- a/configure.ac	Sun Aug 04 22:11:20 2013 -0700
+++ b/configure.ac	Sat Aug 03 15:38:47 2013 +0200
@@ -869,7 +869,7 @@
 LIBS="$Z_LDFLAGS $Z_LIBS $LIBS"
 OCTAVE_CHECK_LIB(glpk, GLPK,
   [GLPK library not found.  The glpk function for solving linear programs will be disabled.],
-  [glpk/glpk.h glpk.h], [_glp_lpx_simplex])
+  [glpk/glpk.h glpk.h], [glp_simplex])
 LIBS="$save_LIBS"
 CPPFLAGS="$save_CPPFLAGS"