diff configure.ac @ 9946:55061c7c8d6e

start using gnulib
author John W. Eaton <jwe@octave.org>
date Wed, 09 Dec 2009 01:36:50 -0500
parents f0f7c2477cdb
children cc7ea6083774
line wrap: on
line diff
--- a/configure.ac	Tue Dec 08 18:48:25 2009 -0500
+++ b/configure.ac	Wed Dec 09 01:36:50 2009 -0500
@@ -29,7 +29,7 @@
 EXTERN_CFLAGS="$CFLAGS"
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
-AC_INIT([GNU Octave], [3.3.50+], [bug@octave.org], [octave], [http://www.octave.org])
+AC_INIT([GNU Octave], [3.3.50+], [bug@octave.org], [octave])
 
 dnl PACKAGE_VERSION is set by the AC_INIT VERSION arg
 OCTAVE_VERSION="$PACKAGE_VERSION"
@@ -43,13 +43,15 @@
 AC_SUBST(OCTAVE_RELEASE_DATE)
 AC_SUBST(OCTAVE_COPYRIGHT)
 
-AM_INIT_AUTOMAKE([1.11 tar-ustar])
 AC_REVISION($Revision: 1.603 $)
 AC_PREREQ([2.62])
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER([config.h])
+AC_CONFIG_AUX_DIR([build-aux])
 AC_CONFIG_MACRO_DIR([m4])
 
+AM_INIT_AUTOMAKE([1.11 tar-ustar])
+
 OCTAVE_HOST_TYPE
 
 AC_DEFINE(OCTAVE_SOURCE, 1, [Define if this is Octave.])
@@ -227,6 +229,11 @@
 AC_PROG_CPP
 AC_PROG_GCC_TRADITIONAL
 
+### gnulib
+
+gl_EARLY
+gl_INIT
+
 ### Do special things for gcc.
 
 gcc_version=`$CC -v 2>&1 | grep "^.*gcc version" | \
@@ -1494,17 +1501,6 @@
    ;;
 esac
 
-case "$canonical_host_type" in
-  *-*-msdosmsvc | *-*-mingw*)
-    ## The %T and %e format specifiers for strftime are not implemented
-    ## so use our version.  We could use an actual configure test
-    ## for this.
-  ;;
-  *)
-    AC_CHECK_FUNCS(strftime)
-  ;;
-esac
-
 OCTAVE_HAVE_C99_VSNPRINTF
 OCTAVE_STRPTIME_BROKEN
 OCTAVE_SMART_PUTENV
@@ -2143,6 +2139,7 @@
   examples/Makefile
   libcruft/Makefile
   libcruft/mkf77def
+  libgnu/Makefile
   liboctave/Makefile
   scripts/Makefile
   src/Makefile