diff configure.ac @ 10332:5f6298220ced

configure.ac: include colamd and amd libs in LIBS when checking for cholmod library
author John W. Eaton <jwe@octave.org>
date Wed, 17 Feb 2010 14:24:22 -0500
parents 6a50aa2cdf00
children 43145faf9af8
line wrap: on
line diff
--- a/configure.ac	Wed Feb 17 14:46:51 2010 -0500
+++ b/configure.ac	Wed Feb 17 14:24:22 2010 -0500
@@ -984,7 +984,7 @@
 # then you will need to configure with --with-cholmod="-lcholmod -lcblas".
 
 save_LIBS="$LIBS"
-LIBS="$LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS"
+LIBS="$COLAMD_LDFLAGS $COLAMD_LIBS $AMD_LDFLAGS $AMD_LIBS $LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS"
 OCTAVE_CHECK_LIBRARY(cholmod, CHOLMOD,
   [CHOLMOD library not found.  This will result in some lack of functionality for sparse matrices.],
   [suitesparse/cholmod.h ufsparse/cholmod.h cholmod/cholmod.h cholmod.h],