diff libinterp/Makefile.am @ 15418:60090630cb76

generate declarations for all built-in DEFUN functions * mkbuiltins: New options, --source and --header. With --header, generate declarations for DEFUN functions. * libinterp/Makefile.am (builtin-defun-decls.h): New rule. (builtins.cc): Use --source option for mkbuiltins. (BUILT_SOURCES, BUILT_NODISTFILES, octinclude_HEADERS, nodist_liboctinterp_la_SOURCES): Add builtin-defun-decls.h to the list. * builtins.h: Include builtin-defun-decls.h.
author John W. Eaton <jwe@octave.org>
date Wed, 19 Sep 2012 13:24:32 -0400
parents dd371063e414
children dd086145f4a6
line wrap: on
line diff
--- a/libinterp/Makefile.am	Wed Sep 19 10:17:35 2012 -0700
+++ b/libinterp/Makefile.am	Wed Sep 19 13:24:32 2012 -0400
@@ -53,6 +53,7 @@
   interpfcn/defaults.h \
   interpfcn/graphics-props.cc \
   interpfcn/graphics.h \
+  builtin-defun-decls.h \
   operators/ops.cc \
   parse-tree/lex.cc \
   parse-tree/oct-gperf.h \
@@ -73,6 +74,7 @@
   interp-core/oct-errno.cc \
   interpfcn/defaults.h \
   interpfcn/graphics.h \
+  builtin-defun-decls.h \
   operators/ops.cc \
   oct-conf.h \
   version.h \
@@ -100,6 +102,7 @@
   interpfcn/graphics-props.cc \
   parse-tree/oct-gperf.h \
   builtins.h \
+  builtin-defun-decls.h \
   octave.h \
   $(OCTAVE_VALUE_INC) \
   $(PARSE_TREE_INC) \
@@ -157,6 +160,7 @@
   interpfcn/defaults.h \
   interpfcn/graphics.h \
   operators/ops.cc \
+  builtin-defun-decls.h \
   builtins.cc \
   oct-conf.h \
   version.h \
@@ -246,7 +250,11 @@
 	mv $@-t $@
 
 builtins.cc: $(DEF_FILES) mkbuiltins
-	$(srcdir)/mkbuiltins $(DEF_FILES) > $@-t
+	$(srcdir)/mkbuiltins --source $(DEF_FILES) > $@-t
+	mv $@-t $@
+
+builtin-defun-decls.h: $(SRC_DEF_FILES) mkbuiltins
+	$(srcdir)/mkbuiltins --header $(SRC_DEF_FILES) > $@-t
 	mv $@-t $@
 
 if AMCOND_ENABLE_DYNAMIC_LINKING