diff configure.in @ 3249:60866c521b92

[project @ 1999-07-13 03:44:16 by jwe]
author jwe
date Tue, 13 Jul 1999 03:46:16 +0000
parents 041ea33fbbf4
children 7ae1928ca623
line wrap: on
line diff
--- a/configure.in	Tue Jul 13 03:40:17 1999 +0000
+++ b/configure.in	Tue Jul 13 03:46:16 1999 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.316 $)
+AC_REVISION($Revision: 1.317 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -386,9 +386,8 @@
       fi
       case "$canonical_host_type" in
         alpha*-*-*)
-          if test "$octave_cv_f77_is_g77" = yes \
-	      || test -z "$ieee_fp_flag" ; then
-            true
+          if test "$octave_cv_f77_is_g77" = yes; then
+            FFLAGS="$ieee_fp_flag $FFLAGS"
 	  else
 	    FFLAGS="-fpe1 $FFLAGS"
 	  fi
@@ -707,21 +706,23 @@
 AC_HEADER_TIME
 AC_HEADER_SYS_WAIT
 
+AC_CHECK_HEADERS(assert.h curses.h dlfcn.h fcntl.h float.h floatingpoint.h \
+  fnmatch.h glob.h grp.h ieeefp.h limits.h memory.h nan.h ncurses.h \
+  pwd.h sgtty.h stdlib.h string.h sys/ioctl.h sys/param.h sys/resource.h \
+  sys/select.h sys/stat.h sys/time.h sys/times.h sys/types.h \
+  sys/utsname.h termcap.h termio.h $TERMIOS_H unistd.h varargs.h)
+
 ### I'm told that termios.h is broken on NeXT systems.
 
-TERMIOS_H=termios.h
 case "$canonical_host_type" in
   *-*-nextstep*)
-    TERMIOS_H=
+    if test "$ac_cv_header_termios_h" = yes; then
+      AC_MSG_WARN([Ignoring termios.h on NeXT systems.])
+      ac_cv_header_termios_h=no
+    fi
   ;;
 esac
 
-AC_CHECK_HEADERS(assert.h curses.h dlfcn.h fcntl.h float.h floatingpoint.h \
-  fnmatch.h glob.h grp.h ieeefp.h limits.h memory.h nan.h ncurses.h \
-  pwd.h sgtty.h stdlib.h string.h sys/param.h sys/resource.h \
-  sys/select.h sys/stat.h sys/time.h sys/times.h sys/types.h \
-  sys/utsname.h termcap.h termio.h $TERMIOS_H unistd.h varargs.h)
-
 if test "$ac_cv_header_termios_h" = yes \
     || test "$ac_cv_header_termio_h" = yes \
     || test "$ac_cv_header_sgtty_h" = yes; then