diff configure.ac @ 10259:65b41bc71f09

use gnulib fcntl module
author John W. Eaton <jwe@octave.org>
date Wed, 03 Feb 2010 17:05:02 -0500
parents cd550069240e
children 82db36545def
line wrap: on
line diff
--- a/configure.ac	Wed Feb 03 15:27:53 2010 -0500
+++ b/configure.ac	Wed Feb 03 17:05:02 2010 -0500
@@ -1448,7 +1448,7 @@
 
 ### C headers
 
-AC_CHECK_HEADERS(curses.h direct.h dlfcn.h fcntl.h \
+AC_CHECK_HEADERS(curses.h direct.h dlfcn.h \
   floatingpoint.h grp.h ieeefp.h inttypes.h locale.h memory.h nan.h \
   ncurses.h poll.h pthread.h pwd.h sunmath.h sys/ioctl.h \
   sys/param.h sys/poll.h sys/resource.h sys/select.h \
@@ -1489,7 +1489,7 @@
 ### Checks for functions and variables.
 
 AC_CHECK_FUNCS(basename canonicalize_file_name \
-  chmod dup2 endgrent endpwent execvp expm1 expm1f fcntl fork \
+  chmod dup2 endgrent endpwent execvp expm1 expm1f fork \
   getegid geteuid getgid getgrent getgrgid getgrnam getpgrp getpid \
   getppid getpwent getpwuid getuid getwd _kbhit kill \
   lgamma lgammaf lgamma_r lgammaf_r localtime_r log1p log1pf \