diff configure.ac @ 10346:65d5776379c3

Reduce the amount of stuff included by windows.h and avoid min/max being #define-d
author Michael Goffioul <michael.goffioul@gmail.com>
date Sun, 21 Feb 2010 18:04:59 +0000
parents 43145faf9af8
children 60acc47c203f
line wrap: on
line diff
--- a/configure.ac	Sun Feb 21 17:46:30 2010 +0000
+++ b/configure.ac	Sun Feb 21 18:04:59 2010 +0000
@@ -430,6 +430,11 @@
 AC_SUBST(XTRA_CFLAGS)
 AC_SUBST(XTRA_CXXFLAGS)
 
+## Avoid #define of min/max from windows.h header
+if test "$have_msvc" = "yes"; then
+  AC_DEFINE(NOMINMAX, 1, [Define if you want to avoid min/max macro definition in Windows headers])
+fi
+
 ### Use -static if compiling on Alpha OSF/1 1.3 systems.
 
 case "$canonical_host_type" in