diff configure.in @ 5854:68f8017ef077

[project @ 2006-06-12 15:54:27 by jwe]
author jwe
date Mon, 12 Jun 2006 15:54:27 +0000
parents 034cdbd34c0a
children 6a558a8763df
line wrap: on
line diff
--- a/configure.in	Fri Jun 09 22:49:32 2006 +0000
+++ b/configure.in	Mon Jun 12 15:54:27 2006 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.513 $)
+AC_REVISION($Revision: 1.514 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -207,6 +207,7 @@
 
 OCTAVE_CXX_NEW_FRIEND_TEMPLATE_DECL
 OCTAVE_CXX_ISO_COMPLIANT_LIBRARY
+OCTAVE_CXX_BROKEN_REINTERPRET_CAST
 
 # Determine the ABI used the C++ compiler, needed by the dynamic loading
 # code. Currently supported ABIs are GNU v2, GNU v3 and Sun Workshop.
@@ -1632,6 +1633,12 @@
 
 #define X_CAST(T, E) (T) (E)
 
+#if defined (CXX_BROKEN_REINTERPRET_CAST)
+#define FCN_PTR_CAST(T, E) (T) (E)
+#else
+#define FCN_PTR_CAST(T, E) reinterpret_cast<T> (E)
+#endif
+
 #if defined(HAVE_F2C) && !defined(F77_FUNC)
 #  define F77_FUNC(x,X) x ## _
 #  define F77_FUNC_(x,X) x ## __