diff configure.ac @ 15350:6a0c0d3d60b6

build: Implement some caching for OCTAVE_CHECK_LIB macro. * configure.ac: Update variable names that have changed in OCTAVE_CHECK_LIB. * acinclude.m4 (OCTAVE_CHECK_LIB): Implement caching for the library check portion of macro.
author Rik <rik@octave.org>
date Tue, 11 Sep 2012 10:30:32 -0700
parents 90c2b2d777bf
children 01c4f5d8a656
line wrap: on
line diff
--- a/configure.ac	Tue Sep 11 07:55:37 2012 -0700
+++ b/configure.ac	Tue Sep 11 10:30:32 2012 -0700
@@ -1230,7 +1230,7 @@
   [sqr1up],
   [Fortran 77], [don't use qrupdate, disable QR & Cholesky updating functions])
 
-if test "$octave_qrupdate_ok" = yes; then
+if test "$octave_cv_lib_qrupdate" = yes; then
   LIBS="$LIBS $QRUPDATE_LIBS"
   AC_LANG_PUSH([Fortran 77])
   AC_MSG_CHECKING([for slup1up in $QRUPDATE_LIBS])
@@ -1313,6 +1313,7 @@
 if test -z "$UMFPACK_LIBS"; then
   ## Invalidate the cache and try again with -lcblas.
   $as_unset ac_cv_lib_umfpack_umfpack_zi_get_determinant
+  $as_unset octave_cv_lib_umfpack
   save_LIBS="$LIBS"
   LIBS="-lcblas $AMD_LDFLAGS $AMD_LIBS $BLAS_LIBS $FLIBS $LIBS"
   OCTAVE_CHECK_LIB([umfpack], UMFPACK,