diff src/Makefile.am @ 13016:6b0798860fa4

maint: let libtool deal with setting -rpath linker option * configure.ac (--enable-rpath): Delete option handler. (RLD_FLAG): Delete variable and all uses. * common.mk (RLD_FLAG): Don't substitute it. (do_subst_config_vals): Don't substitute OCTAVE_CONF_RLD_FLAG. * oct-conf.h.in (OCTAVE_CONF_RLD_FLAG): Delete definition. * toplev.cc (octave_config_info): Delete RLD_FLAG from the list. * libcruft/Makefile.am, liboctave/Makefile.am, src/Makefile.am, src/link-deps.mk: Don't add RLD_FLAG to link options.
author John W. Eaton <jwe@octave.org>
date Sat, 27 Aug 2011 11:28:48 -0400
parents edc5ec6e949b
children 05534f03377d
line wrap: on
line diff
--- a/src/Makefile.am	Sat Aug 27 11:23:17 2011 -0400
+++ b/src/Makefile.am	Sat Aug 27 11:28:48 2011 -0400
@@ -517,7 +517,6 @@
 liboctinterp_version_info = $(liboctinterp_current):$(liboctinterp_revision):$(liboctinterp_age)
 
 liboctinterp_la_LDFLAGS = \
-  $(RLD_FLAG) \
   -version-info $(liboctinterp_version_info) \
   $(NO_UNDEFINED_LDFLAG) \
   -bindir $(bindir) \
@@ -527,7 +526,7 @@
 
 octave_SOURCES = main.c
 
-octave_LDADD = liboctinterp.la $(OCTAVE_LINK_DEPS)
+octave_LDADD = liboctinterp.la ../liboctave/liboctave.la ../libcruft/libcruft.la $(OCTAVE_LINK_DEPS)
 
 octave_LDFLAGS = $(OCTAVE_LINK_OPTS)