diff test/Makefile.am @ 13147:6c952376482d

look for methods before constructors * symtab.cc (symbol_table::fcn_info::fcn_info_rep::find): Look for class methods before constructors, contrary to Matlab documentation. * test/ctor-vs-method: New directory of test classes. * test/test_ctor_vs_method.m: New file. * test/Makefile.am: Include ctor-vs-method/module.mk. (FCN_FILES): Include test_ctor_vs_method.m in the list.
author John W. Eaton <jwe@octave.org>
date Fri, 16 Sep 2011 15:42:06 -0400
parents 98d23b0f16e1
children 968e89b45bbf
line wrap: on
line diff
--- a/test/Makefile.am	Fri Sep 16 21:04:30 2011 +0200
+++ b/test/Makefile.am	Fri Sep 16 15:42:06 2011 -0400
@@ -25,6 +25,7 @@
   test_args.m \
   test_classes.m \
   test_contin.m \
+  test_ctor_vs_method.m \
   test_diag_perm.m \
   test_error.m \
   test_eval-catch.m \
@@ -61,6 +62,8 @@
 include @Snork/module.mk
 include @Spork/module.mk
 
+include ctor-vs-method/module.mk
+
 check: test_sparse.m test_bc_overloads.m
 	$(top_builddir)/run-octave --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)