diff configure.ac @ 9707:6f5c4c82c5fc

avoid ugly F77 names in configure
author Jaroslav Hajek <highegg@gmail.com>
date Thu, 08 Oct 2009 12:18:45 +0200
parents 11844593875a
children 6f3ffe11d926
line wrap: on
line diff
--- a/configure.ac	Thu Oct 08 08:09:12 2009 +0200
+++ b/configure.ac	Thu Oct 08 12:18:45 2009 +0200
@@ -903,8 +903,8 @@
 OCTAVE_CHECK_LIBRARY(qrupdate, qrupdate,
   [qrupdate not found.  The QR & Cholesky updating functions will be slow.],
   [],
-  [F77_FUNC(sqr1up,SQR1UP)],
-  [], [don't use qrupdate, disable QR & Cholesky updating functions])
+  [sqr1up],
+  [Fortran 77], [don't use qrupdate, disable QR & Cholesky updating functions])
 LIBS="$save_LIBS"
 
 # Check for AMD library
@@ -998,8 +998,8 @@
 OCTAVE_CHECK_LIBRARY(arpack, ARPACK,
   [arpack not found.  The eigs function will be disabled.],
   [],
-  [F77_FUNC(dseupd,DSEUPD)],
-  [], [don't use the ARPACK library, disable eigs function])
+  [dseupd],
+  [Fortran 77], [don't use the ARPACK library, disable eigs function])
 LIBS="$save_LIBS"
 
 ### Handle shared library options.