diff configure.ac @ 16662:72665c4ae25b

allow build to continue without QScintilla lexer for Octave * configure.ac: Check for Qsci/qscilexeroctave.h and Qsci/qscilexermatlab.h. * file-editor-tab.cc: Include Qsci/qscilexeroctave.h if it is available, otherwise include Qsci/qscilexermatlab.h if it is available. (file_editor_tab::update_lexer): For Octave files, use QsciLexerOctave if it is available, otherwise use QsciLexerMatlab if it is available, otherwise use default lexer.
author John W. Eaton <jwe@octave.org>
date Wed, 15 May 2013 01:30:16 -0400
parents 608e307b4914
children c7d4146c570d
line wrap: on
line diff
--- a/configure.ac	Tue May 14 05:24:19 2013 -0400
+++ b/configure.ac	Wed May 15 01:30:16 2013 -0400
@@ -2648,6 +2648,13 @@
       OCTAVE_CHECK_FUNC_FINDFIRST_MODERN
       AC_DEFINE(HAVE_QSCINTILLA, 1, 
         [Define to 1 if the QScintilla library and header files are available])
+
+      save_CPPFLAGS="$CPPFLAGS"
+      CPPFLAGS="$QT_CPPFLAGS $CPPFLAGS"
+      AC_LANG_PUSH(C++)
+      AC_CHECK_HEADERS([Qsci/qscilexeroctave.h Qsci/qscilexermatlab.h])
+      AC_LANG_POP(C++)
+      CPPFLAGS="$save_CPPFLAGS"
     fi
 
     AC_CHECK_FUNCS([setlocale], [],