diff configure.ac @ 12710:762d10c77277 stable

maint: use libdir for .oct files, not libexecdir From Orion Poplawski <orion@cora.nwra.com>. * configure.ac (octlibdir): Use octave/$(version), not octave-$(version). (octfiledir): Use $(libdir), not $(libexecdir). (localoctfiledir): Likewise. (localapioctfiledir): Likewise. (localveroctfiledir): Likewise. * pkg.m: Use libdir instead of libexecdir as needed.
author John W. Eaton <jwe@octave.org>
date Mon, 06 Jun 2011 11:54:15 -0400
parents 6a225fb7d361
children 630068170ef0
line wrap: on
line diff
--- a/configure.ac	Thu Jun 02 17:44:51 2011 -0400
+++ b/configure.ac	Mon Jun 06 11:54:15 2011 -0400
@@ -125,7 +125,7 @@
   '$(datadir)/octave/site/$(api_version)/m')
 OCTAVE_SET_DEFAULT(localverfcnfiledir, '$(datadir)/octave/$(version)/site/m')
 OCTAVE_SET_DEFAULT(octetcdir, '$(datadir)/octave/$(version)/etc')
-OCTAVE_SET_DEFAULT(octlibdir, '$(libdir)/octave-$(version)')
+OCTAVE_SET_DEFAULT(octlibdir, '$(libdir)/octave/$(version)')
 OCTAVE_SET_DEFAULT(archlibdir,
   '$(libexecdir)/octave/$(version)/exec/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(localarchlibdir,
@@ -135,13 +135,13 @@
 OCTAVE_SET_DEFAULT(localverarchlibdir,
   '$(libexecdir)/octave/$(version)/site/exec/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(octfiledir,
-  '$(libexecdir)/octave/$(version)/oct/$(canonical_host_type)')
+  '$(libdir)/octave/$(version)/oct/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(localoctfiledir,
-  '$(libexecdir)/octave/site/oct/$(canonical_host_type)')
+  '$(libdir)/octave/site/oct/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(localapioctfiledir,
-  '$(libexecdir)/octave/site/oct/$(api_version)/$(canonical_host_type)')
+  '$(libdir)/octave/site/oct/$(api_version)/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(localveroctfiledir,
-  '$(libexecdir)/octave/$(version)/site/oct/$(canonical_host_type)')
+  '$(libdir)/octave/$(version)/site/oct/$(canonical_host_type)')
 OCTAVE_SET_DEFAULT(imagedir, '$(datadir)/octave/$(version)/imagelib')
 
 ### Find pkg-config executable (sets $PKG_CONFIG)