diff configure.in @ 9540:79b5fe2d5646

use Z_LIBS in checks for curl and glpk libraries
author John W. Eaton <jwe@octave.org>
date Tue, 18 Aug 2009 12:10:16 -0400
parents d0239bddf621
children f5ec5dc66824
line wrap: on
line diff
--- a/configure.in	Tue Aug 18 11:23:03 2009 -0400
+++ b/configure.in	Tue Aug 18 12:10:16 2009 -0400
@@ -558,15 +558,27 @@
 
 # Checks for GLPK header and library.
 
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$Z_CPPFLAGS $CPPFLAGS"
+save_LIBS="$LIBS"
+LIBS="$Z_LDFLAGS $Z_LIBS $LIBS"
 OCTAVE_CHECK_LIBRARY(glpk, GLPK,
   [GLPK library not found.  The glpk function for solving linear programs will be disabled.],
   [glpk/glpk.h glpk.h], [_glp_lpx_simplex])
+LIBS="$save_LIBS"
+CPPFLAGS="$save_CPPFLAGS"
 
 # Checks for CURL header and library.
 
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$Z_CPPFLAGS $CPPFLAGS"
+save_LIBS="$LIBS"
+LIBS="$Z_LDFLAGS $Z_LIBS $LIBS"
 OCTAVE_CHECK_LIBRARY(curl, cURL,
   [cURL library not found.  The urlread and urlwrite functions will be disabled.],
   [curl/curl.h], [curl_easy_escape])
+LIBS="$save_LIBS"
+CPPFLAGS="$save_CPPFLAGS"
 
 # GraphicsMagick++