diff configure.in @ 3225:7aae2c3636a7

[project @ 1998-12-04 23:20:12 by jwe]
author jwe
date Fri, 04 Dec 1998 23:20:26 +0000
parents dae85431bade
children 3f6ae91e86b0
line wrap: on
line diff
--- a/configure.in	Fri Dec 04 22:08:23 1998 +0000
+++ b/configure.in	Fri Dec 04 23:20:26 1998 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.312 $)
+AC_REVISION($Revision: 1.313 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -689,11 +689,20 @@
 AC_HEADER_TIME
 AC_HEADER_SYS_WAIT
 
+### I'm told that termios.h is broken on NeXT systems.
+
+TERMIOS_H=termios.h
+case "$canonical_host_type" in
+  *-*-nextstep*)
+    TERMIOS_H=
+  ;;
+esac
+
 AC_CHECK_HEADERS(assert.h curses.h dlfcn.h fcntl.h float.h floatingpoint.h \
   fnmatch.h glob.h grp.h ieeefp.h limits.h memory.h nan.h ncurses.h \
   pwd.h sgtty.h stdlib.h string.h sys/param.h sys/resource.h \
   sys/select.h sys/stat.h sys/time.h sys/times.h sys/types.h \
-  sys/utsname.h termcap.h termio.h termios.h unistd.h varargs.h)
+  sys/utsname.h termcap.h termio.h $TERMIOS_H unistd.h varargs.h)
 
 if test "$ac_cv_header_termios_h" = yes \
     || test "$ac_cv_header_termio_h" = yes \
@@ -751,7 +760,7 @@
   gettimeofday getuid getwd lstat memmove mkdir mkfifo on_exit pipe \
   putenv rename rindex rmdir setgrent setpwent setvbuf sigaction \
   sigpending sigprocmask sigsuspend stat strcasecmp strdup strerror \
-  stricmp strncasecmp strnicmp tempnam umask unlink usleep \
+  strftime stricmp strncasecmp strnicmp tempnam umask unlink usleep \
   vfprintf vsprintf waitpid)
 
 OCTAVE_SMART_PUTENV