diff src/Makefile.am @ 18158:8071c0a9d193

maint: Periodic merge of gui-release to default.
author John W. Eaton <jwe@octave.org>
date Sat, 21 Dec 2013 13:44:53 -0500
parents 6762a6d23010 91a3858ef8cf
children c56ce7c65019
line wrap: on
line diff
--- a/src/Makefile.am	Fri Dec 13 17:24:57 2013 -0500
+++ b/src/Makefile.am	Sat Dec 21 13:44:53 2013 -0500
@@ -49,8 +49,11 @@
   octave \
   octave-cli
 
+OCTAVE_VERSION_LINKS = octave-cli-$(version)
+
 if AMCOND_BUILD_GUI
   OCTAVE_BINARIES += octave-gui
+  OCTAVE_VERSION_LINKS += octave-gui-$(version)
 endif
 
 OCTAVE_CORE_LIBS = \
@@ -136,6 +139,8 @@
   octave-config
 endif
 
+all-local: $(OCTAVE_VERSION_LINKS)
+
 if AMCOND_BUILD_COMPILED_AUX_PROGRAMS
 octave-config.cc: octave-config.in.cc Makefile
 	@$(do_subst_default_vals)
@@ -189,5 +194,17 @@
 
 .PHONY: make-version-links remove-version-links
 
+## We need these file names in the build tree because the wrapper
+## program (main.cc) will try to invoke the versioned binaries.
+
+octave-cli-$(version): octave-cli
+	rm -f $@
+	$(LN_S) $< $@
+
+octave-gui-$(version): octave-gui
+	rm -f $@
+	$(LN_S) $< $@
+
 CLEANFILES = \
-  $(bin_SCRIPTS)
+  $(bin_SCRIPTS) \
+  $(OCTAVE_VERSION_LINKS)