diff libinterp/Makefile.am @ 17378:813523c2b581

build: Use convenience library to build tex-parser so "old-style cast" warning can be disabled. * libinterp/Makefile.am: Place EXTRA_DIST targets for subdirs in subdir/module.mk for more logical grouping. Add libtex_parser.la to octinterp LIBADD variable. * libinterp/corefcn/module.mk: Add new TEX_PARSER_INC, TEX_PARSER_SRC definitions. Add new convenience library libtex_parser.la where CXXFLAGS do not include "-Wold-style-cast". * libinterp/parse-tree/module.mk: Add parse-tree/oct-parse.in.yy to local EXTRA_DIST variable.
author Rik <rik@octave.org>
date Thu, 05 Sep 2013 16:11:19 -0700
parents f0e3d3de5c22
children 7542f4496974
line wrap: on
line diff
--- a/libinterp/Makefile.am	Thu Sep 05 10:34:09 2013 -0700
+++ b/libinterp/Makefile.am	Thu Sep 05 16:11:19 2013 -0700
@@ -91,8 +91,6 @@
   Makefile.in \
   DOCSTRINGS \
   config-features.sh \
-  corefcn/oct-tex-lexer.in.ll \
-  corefcn/oct-tex-symbols.in \
   find-defun-files.sh \
   gendoc.pl \
   genprops.awk \
@@ -102,7 +100,6 @@
   mkdefs \
   mkops \
   oct-conf.in.h \
-  parse-tree/oct-parse.in.yy \
   version.in.h \
   $(BUILT_DISTFILES)
 
@@ -130,7 +127,8 @@
   $(OCTAVE_VALUE_SRC) \
   $(PARSE_TREE_SRC) \
   $(PARSER_SRC) \
-  $(COREFCN_SRC)
+  $(COREFCN_SRC) \
+  $(TEX_PARSER_SRC)
 
 noinst_LTLIBRARIES =
 
@@ -181,6 +179,7 @@
   parse-tree/libparse-tree.la \
   parse-tree/libparser.la \
   corefcn/libcorefcn.la \
+  corefcn/libtex_parser.la \
   $(top_builddir)/liboctave/liboctave.la \
   $(LIBOCTINTERP_LINK_DEPS)