diff configure.ac @ 17821:82c94987abc6

build: Remove REGEX_CPPFLAGS from XTRA_CXXFLAGS. Rename REGEX to PCRE to accurately name the library. * configure.ac: Remove REGEX_CPPFLAGS from XTRA_CXXFLAGS. Rename REGEX to PCRE to accurately name the library. * build-aux/common.mk: Add PCRE_LIBS, PCRE_CPPFLAGS macro substitutions. Delete REGEX_LIBS. * liboctave/util/module.mk: Add PCRE_CPPFLAGS to util convenience library. * liboctave/link-deps.mk: Rename REGEX_LIBS to PCRE_LIBS. libinterp/link-deps.mk: : Remove REGEX_LIBS which was never required for libinterp. * libinterp/corefcn/toplev.cc, libinterp/oct-conf.in.h: Rename REGEX to PCRE to accurately name the library.
author Rik <rik@octave.org>
date Thu, 31 Oct 2013 21:15:00 -0700
parents 3488d987eb50
children b1610bf6d9a8
line wrap: on
line diff
--- a/configure.ac	Thu Oct 31 17:10:38 2013 -0700
+++ b/configure.ac	Thu Oct 31 21:15:00 2013 -0700
@@ -664,7 +664,7 @@
 
 ### Check for PCRE regex library.
 
-REGEX_LIBS=
+PCRE_LIBS=
 
 pcre_fail_msg="to build Octave, you must have the PCRE library and header files installed"
 
@@ -687,18 +687,19 @@
     ac_cv_pcre_h_macros_present=yes, ac_cv_pcre_h_macros_present=no)])
 
 if test $ac_cv_pcre_h_macros_present = yes; then
-  ## check for pcre-config, and if so, set XTRA_CXXFLAGS appropriately
+  ## check for pcre-config, and if so, get build variables
   AC_CHECK_PROG(HAVE_PCRE_CONFIG, pcre-config, [yes], [no])
   if test $HAVE_PCRE_CONFIG = yes; then
-    XTRA_CXXFLAGS="$XTRA_CXXFLAGS `pcre-config --cflags`"
-    REGEX_LIBS=`pcre-config --libs`
+    PCRE_CPPFLAGS=`pcre-config --cflags`
+    PCRE_LIBS=`pcre-config --libs`
   else
-    REGEX_LIBS="-lpcre"
+    PCRE_LIBS="-lpcre"
   fi
   save_LIBS="$LIBS"
-  LIBS="$REGEX_LIBS $LIBS"
+  LIBS="$PCRE_LIBS $LIBS"
   AC_CHECK_FUNCS([pcre_compile],
-    [AC_SUBST(REGEX_LIBS)],
+    [AC_SUBST(PCRE_CPPFLAGS)
+     AC_SUBST(PCRE_LIBS)],
     [AC_MSG_ERROR([$pcre_fail_msg])])
   LIBS="$save_LIBS"
 else
@@ -2852,6 +2853,8 @@
   Magick++ LDFLAGS:            $MAGICK_LDFLAGS
   Magick++ libraries:          $MAGICK_LIBS
   OPENGL libraries:            $OPENGL_LIBS
+  PCRE CPPFLAGS:               $PCRE_CPPFLAGS
+  PCRE libraries:              $PCRE_LIBS
   PTHREAD flags:               $PTHREAD_CFLAGS
   PTHREAD libraries:           $PTHREAD_LIBS
   QHULL CPPFLAGS:              $QHULL_CPPFLAGS
@@ -2864,7 +2867,6 @@
   Qt LDFLAGS:                  $QT_LDFLAGS
   Qt libraries:                $QT_LIBS
   READLINE libraries:          $READLINE_LIBS
-  REGEX libraries:             $REGEX_LIBS
   TERM libraries:              $TERM_LIBS
   UMFPACK CPPFLAGS:            $UMFPACK_CPPFLAGS
   UMFPACK LDFLAGS:             $UMFPACK_LDFLAGS