diff configure.ac @ 10266:82db36545def

use gnulib gethostname module
author John W. Eaton <jwe@octave.org>
date Thu, 04 Feb 2010 04:43:08 -0500
parents 65b41bc71f09
children 6a50aa2cdf00
line wrap: on
line diff
--- a/configure.ac	Thu Feb 04 03:56:28 2010 -0500
+++ b/configure.ac	Thu Feb 04 04:43:08 2010 -0500
@@ -1370,18 +1370,13 @@
 AC_SUBST(SCRIPTS_EXE_SUFFIX)
 
 ### special checks for odd OS specific things.
-###
-### I am told that on some SCO systems, the only place to find some
-### functions like gethostname and gettimeofday is in libsocket.
 
-AC_CHECK_FUNCS(gethostname, [], [AC_CHECK_LIB(socket, gethostname)])
 AC_CHECK_FUNCS(getpwnam, [], [AC_CHECK_LIB(sun, getpwnam)])
 
 NO_UNDEFINED_LDFLAG=
 case "$canonical_host_type" in
   *-*-cygwin*)
-   AC_CHECK_LIB(wsock32, gethostname)
-   LIBS="$LIBS -lwsock32"
+    LIBS="$LIBS -lwsock32"
   ;;
   *-*-mingw*)
     if test "$have_msvc" = "yes"; then