diff configure.ac @ 14144:834df9f10963 stable

remove ARPACK files from sources and restore configure checks for external ARPACK library * libcruft/arpack: Remove directory and all files. * libcruft/Makefile.am: Don't include arpack/module.mk. * m4/acinclude.m4 (OCTAVE_CHECK_ARPACK_OK): New macro. * configure.ac: Check for ARPACK. Use OCTAVE_CHECK_ARPACK_OK to test for known bug. * build-aux/common.mk (ARPACK_CPPFLAGS, ARPACK_LDFLAGS, ARPACK_LIBS): Restore variables. (do_subst_config_vals): Substitute them. * eigs-base.cc: Use HAVE_ARPACK again. * sparse/svds.m: Use "testif HAVE_ARPACK" instead of "test". * DLD-FUNCTIONS/eigs.cc (Feigs): Restore HAVE_ARPACK conditionals. Use "testif HAVE_ARPACK" instead of "test". * toplev.cc (octave_config_info): Restore ARPACK_CPPFLAGS, ARPACK_LDFLAGS, ARPACK_LIBS to the struct. * oct-conf.h.in (OCTAVE_CONF_ARPACK_CPPFLAGS, OCTAVE_CONF_ARPACK_LDFLAGS, OCTAVE_CONF_ARPACK_LIBS): Restore #defines.
author John W. Eaton <jwe@octave.org>
date Tue, 03 Jan 2012 20:12:38 -0500
parents 72c96de7a403
children f15007a6c642
line wrap: on
line diff
--- a/configure.ac	Tue Jan 03 12:03:12 2012 -0500
+++ b/configure.ac	Tue Jan 03 20:12:38 2012 -0500
@@ -1173,6 +1173,19 @@
   LIBS="$save_LIBS"
 fi
 
+save_LIBS="$LIBS"
+LIBS="$LAPACK_LIBS $BLAS_LIBS $FLIBS $LIBS"
+OCTAVE_CHECK_LIBRARY(arpack, ARPACK,
+  [ARPACK not found.  The eigs function will be disabled.],
+  [],
+  [dseupd],
+  [Fortran 77], [don't use the ARPACK library, disable eigs function],
+  [warn_arpack=
+   OCTAVE_CHECK_ARPACK_OK([
+     AC_DEFINE(HAVE_ARPACK, 1, [Define if ARPACK is available.])], [
+     warn_arpack="ARPACK library found, but seems not to work properly -- disabling eigs function"])])
+LIBS="$save_LIBS"
+
 ### Enable dynamic linking.  --enable-shared implies this, so
 ### --enable-dl is only need if you are only building static libraries
 ### and want to try dynamic linking too (works on some systems, for
@@ -2150,6 +2163,9 @@
   AMD CPPFLAGS:                $AMD_CPPFLAGS
   AMD LDFLAGS:                 $AMD_LDFLAGS
   AMD libraries:               $AMD_LIBS
+  ARPACK CPPFLAGS:             $ARPACK_CPPFLAGS
+  ARPACK LDFLAGS:              $ARPACK_LDFLAGS
+  ARPACK libraries:            $ARPACK_LIBS
   BLAS libraries:              $BLAS_LIBS
   CAMD CPPFLAGS:               $CAMD_CPPFLAGS
   CAMD LDFLAGS:                $CAMD_LDFLAGS
@@ -2395,7 +2411,7 @@
   AC_MSG_WARN([Make.  This should work automatically for gfortran.  If])
   AC_MSG_WARN([you use another compiler, you will need to set this])
   AC_MSG_WARN([variable on the configure command line.  You must also])
-  AC_MSG_WARN([compile the BLAS, LAPACK, QRUPDATE, and SuiteSparse])
+  AC_MSG_WARN([compile the ARPACK, BLAS, LAPACK, QRUPDATE, and SuiteSparse])
   AC_MSG_WARN([libraries to use 8 byte signed integers for array indexing.])
   AC_MSG_WARN([])
   warn_msg_printed=true