diff configure.in @ 4098:8496ae60db8a

[project @ 2002-10-10 05:20:20 by jwe]
author jwe
date Thu, 10 Oct 2002 05:20:21 +0000
parents 3e631060ab8f
children ea537559ab07
line wrap: on
line diff
--- a/configure.in	Wed Oct 09 20:26:27 2002 +0000
+++ b/configure.in	Thu Oct 10 05:20:21 2002 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.373 $)
+AC_REVISION($Revision: 1.374 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -322,23 +322,28 @@
 
 ### Defaults for cross compiling.  BUILD_CC and BUILD_CXX are
 ### the compilers that we use for building tools on the build system.
+### For now, we assume that the only cross compiling we can do is
+### with gcc on a Unixy system.
 
 if test "$cross_compiling" = yes; then
   BUILD_CC="gcc"
   BUILD_CFLAGS="-O2 -g"
   BUILD_CXX="g++"
   BUILD_CXXFLAGS="-O2 -g"
+  BUILD_EXEEXT=""
 else
   BUILD_CC=$CC
   BUILD_CFLAGS="-O2 -g"
   BUILD_CXX="g++"
   BUILD_CXXFLAGS="-O2 -g"
+  BUILD_EXEEXT="$EXEEXT"
 fi
 
 AC_ARG_VAR(BUILD_CC, [build system C compiler (used if cross compiling)])
 AC_ARG_VAR(BUILD_CFLAGS, [build system C compiler flags (used if cross compiling)])
 AC_ARG_VAR(BUILD_CXX, [build system C++ compiler (used if cross compiling)])
 AC_ARG_VAR(BUILD_CXXFLAGS, [build system C++ compiler flags (used if cross compiling)])
+AC_SUBST(BUILD_EXEEXT)
 
 dnl This is bogus.  We shouldn't have to explicitly add libc too!