diff configure.in @ 2032:86d6c42c192a

[project @ 1996-03-26 08:46:39 by jwe]
author jwe
date Tue, 26 Mar 1996 08:47:01 +0000
parents 7093bc725c63
children ce456cebbd7f
line wrap: on
line diff
--- a/configure.in	Tue Mar 26 08:41:10 1996 +0000
+++ b/configure.in	Tue Mar 26 08:47:01 1996 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.177 $)
+AC_REVISION($Revision: 1.178 $)
 AC_PREREQ(2.0)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -950,6 +950,15 @@
   AC_MSG_RESULT([defining DEFAULT_PAGER to be $DEFAULT_PAGER])
 fi
 
+### Even though we include config.h, we need to have the preprocessor
+### defines available in a variable for the octave-bug script.  Use
+### UGLY_DEFS for that.
+
+AC_OUTPUT_MAKE_DEFS
+UGLY_DEFS="$DEFS"
+AC_MSG_RESULT([defining UGLY_DEFS to be $UGLY_DEFS])
+AC_SUBST(UGLY_DEFS)
+
 ### Maybe add -Wall to compiler flags now that we're done feature
 ### testing. 
 ###