diff configure.in @ 6094:86ee3cc8d8d2

[project @ 2006-10-26 01:18:33 by jwe]
author jwe
date Thu, 26 Oct 2006 01:18:34 +0000
parents 96a11041f52b
children 70158d7ab8ef
line wrap: on
line diff
--- a/configure.in	Thu Oct 26 00:32:53 2006 +0000
+++ b/configure.in	Thu Oct 26 01:18:34 2006 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.533 $)
+AC_REVISION($Revision: 1.534 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1318,10 +1318,21 @@
   lstat memmove mkdir mkfifo mkstemp on_exit pipe poll putenv raise \
   readlink rename resolvepath rindex rmdir round select setgrent \
   setlocale setpwent setvbuf sigaction siglongjmp sigpending sigprocmask \
-  sigsuspend stat strcasecmp strdup strerror strftime stricmp \
+  sigsuspend stat strcasecmp strdup strerror stricmp \
   strncasecmp strnicmp strptime strsignal symlink tempnam umask \
   uname unlink usleep vfprintf vsprintf vsnprintf waitpid)
 
+case "$canonical_host_type" in
+  *-*-msdosmsvc)
+    ## The %T format specifier for strftime is reportedly broken,
+    ## so use our version.  We could use an actual configure test
+    ## for this.
+  ;;
+  *)
+    AC_CHECK_FUNCS(strftime)
+  ;;
+esac
+
 OCTAVE_SMART_PUTENV
 
 ### Dynamic linking is now enabled only if we are building shared