diff configure.ac @ 15127:87411930d6c4

avoid "function declared 'noreturn' has a return statement" warning. * configure.ac (HAVE_ATTR_DEPRECATED, HAVE_ATTR_NORETURN, HAVE_ATTR_UNUSED): New macros, corresponding to GCC_ATTR_DEPRECATED, GCC_ATTR_NORETURN, and GCC_ATTR_UNUSED. * libcruft/misc/f77-fcn.c (xstopx): Use F77_NORETURN instead of F77_RETURN. * libcruft/misc/f77-fcn.h (F77_RETURN): New macro.
author John W. Eaton <jwe@octave.org>
date Wed, 08 Aug 2012 10:27:59 -0400
parents 25200c04bc25
children f635710b3090
line wrap: on
line diff
--- a/configure.ac	Wed Aug 08 07:23:21 2012 -0700
+++ b/configure.ac	Wed Aug 08 10:27:59 2012 -0400
@@ -2159,8 +2159,13 @@
 
 #if defined (__GNUC__)
 #define GCC_ATTR_DEPRECATED __attribute__ ((__deprecated__))
+#define HAVE_ATTR_DEPRECATED
+
 #define GCC_ATTR_NORETURN __attribute__ ((__noreturn__))
+#define HAVE_ATTR_NORETURN
+
 #define GCC_ATTR_UNUSED __attribute__ ((__unused__))
+#define HAVE_ATTR_UNUSED
 #else
 #define GCC_ATTR_DEPRECATED
 #define GCC_ATTR_NORETURN