diff configure.in @ 4249:8a1ef8fe4036

[project @ 2002-12-31 04:42:32 by jwe]
author jwe
date Tue, 31 Dec 2002 04:42:33 +0000
parents 40153a2affd6
children f35aa1f0201f
line wrap: on
line diff
--- a/configure.in	Tue Dec 31 00:00:20 2002 +0000
+++ b/configure.in	Tue Dec 31 04:42:33 2002 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.399 $)
+AC_REVISION($Revision: 1.400 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1348,6 +1348,15 @@
 #if defined (sigsetjmp) && defined (HAVE_SIGLONGJMP)
 #define OCTAVE_HAVE_SIG_JUMP
 #endif
+
+#if defined (__GNUG__)
+#define OCTAVE_LOCAL_BUFFER(T, buf, size) \
+  T buf[size]
+#else
+#define OCTAVE_LOCAL_BUFFER(T, buf, size) \
+  std::auto_ptr<T> buf_auto_ptr (new T [size]); \
+  T *buf = buf_auto_ptr.get ()
+#endif
 ])
 
 ### Do the substitutions in all the Makefiles.