diff src/Makefile.am @ 14329:8d1ae996c122

also save and restore symbol table context in parser (bug #35448) * parse-private.h: New file to define new symtab_context class. * Makefile.am (octinclude_HEADERS): Include it in the list. * lex.ll, oct-parse.yy: Include parse-private.h. * lex.ll (reset_parser): Clear parser_symtab_context. * parse.h (symtab_context): Delete variable declaration. * oct-parse.yy (symtab_context): Delete variable definition. (parser_symtab_context): New variable. (ABORT_PARSE, make_anon_fcn_handle, recover_from_parsing_function): Pop parser_symtab_context. (push_fcn_symtab, param_list_beg): Push parser_symtab_context.
author John W. Eaton <jwe@octave.org>
date Sun, 05 Feb 2012 13:53:55 -0500
parents 21572e9bd365
children 4e8f1d1b0d75
line wrap: on
line diff
--- a/src/Makefile.am	Sun Feb 05 13:16:07 2012 -0500
+++ b/src/Makefile.am	Sun Feb 05 13:53:55 2012 -0500
@@ -284,6 +284,7 @@
   ops.h \
   pager.h \
   parse.h \
+  parse-private.h \
   pr-output.h \
   procstream.h \
   profiler.h \