diff configure.in @ 9583:8dc1531e2149

correctly save and restore LIBS and CPPFLAGS when checking for GraphicsMagick++
author John W. Eaton <jwe@octave.org>
date Thu, 27 Aug 2009 15:49:51 -0400
parents 55ecaefb7d0f
children f26229391ea1
line wrap: on
line diff
--- a/configure.in	Thu Aug 27 15:43:09 2009 -0400
+++ b/configure.in	Thu Aug 27 15:49:51 2009 -0400
@@ -585,11 +585,9 @@
   warn_magick="GraphicsMagick++ library fails tests.  The imread function for reading image files will not be fully functional."
 
   save_CPPFLAGS="$CPPFLAGS"
-  save_LDFLAGS="$LDFLAGS"
   save_LIBS="$LIBS"
-  CPPFLAGS="$CPPFLAGS $MAGICK_CPPFLAGS"
-  LDFLAGS="$LIBS $MAGICK_LDFLAGS"
-  LIBS="$LIBS $MAGICK_LIBS"
+  CPPFLAGS="$MAGICK_CPPFLAGS $CPPFLAGS"
+  LIBS="$MAGICK_LDFLAGS $MAGICK_LIBS $LIBS"
   AC_LANG_PUSH(C++)
     AC_CHECK_HEADER([Magick++.h], [
       AC_MSG_CHECKING([for Magick::ColorRGB in Magick++.h])
@@ -602,7 +600,6 @@
     ])
   AC_LANG_POP(C++)
   CPPFLAGS="$save_CPPFLAGS"
-  LDFLAGS="$save_LDFLAGS"
   LIBS="$save_LIBS"
 ])