diff configure.in @ 2020:8e393fad9362

[project @ 1996-03-22 12:21:44 by jwe]
author jwe
date Fri, 22 Mar 1996 12:21:44 +0000
parents 564637605b2a
children 6b129bd50f4a
line wrap: on
line diff
--- a/configure.in	Fri Mar 22 12:16:41 1996 +0000
+++ b/configure.in	Fri Mar 22 12:21:44 1996 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.171 $)
+AC_REVISION($Revision: 1.172 $)
 AC_PREREQ(2.0)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -274,12 +274,25 @@
 
 ### On Linux systems we need to compile with -mieee-fp to get full
 ### support for IEEE floating point.
+###
+### On Alpha/OSF systems, wee need -mieee-with-inexact, but that also
+### requires gcc 2.8.x or later.
 
 case "$canonical_host_type" in
   i[345]86-*-linux)
     GCC_IEEE_FP_FLAG="-mieee-fp"
     AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
   ;;
+  alpha-dec-osf*)
+    case"$gcc_version" in
+      1.* | 2.[01234567].*)
+      ;;
+      *)
+        GCC_IEEE_FP_FLAG="-mieee-with-inexact"
+        AC_MSG_RESULT([defining GCC_IEEE_FP_FLAG to be $GCC_IEEE_FP_FLAG])
+      ;;
+    esac
+  ;;
 esac
 AC_SUBST(GCC_IEEE_FP_FLAG)