diff configure.in @ 4105:92f4552ea359

[project @ 2002-10-16 14:55:38 by jwe]
author jwe
date Wed, 16 Oct 2002 14:55:38 +0000
parents fef735180134
children b9238356dd07
line wrap: on
line diff
--- a/configure.in	Tue Oct 15 20:28:21 2002 +0000
+++ b/configure.in	Wed Oct 16 14:55:38 2002 +0000
@@ -22,7 +22,7 @@
 ### 02111-1307, USA. 
 
 AC_INIT
-AC_REVISION($Revision: 1.378 $)
+AC_REVISION($Revision: 1.379 $)
 AC_PREREQ(2.52)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -658,7 +658,7 @@
   *-*-darwin*)
     SH_LDFLAGS='-bundle -bundle_loader $(bindir)/octave'
   ;;
-  *-*-cygwin*)
+  *-*-cygwin* | *-*-mingw*)
     CXXPICFLAG=
     CPICFLAG=
     FPICFLAG=
@@ -1132,6 +1132,13 @@
 
 ### A system dependent kluge or two.
 
+### Extra libs needed when using the win32api
+case "$cannonical_host_type" in
+  *-*-mingw*)
+    LIBS="-lwsock32 $LIBS"
+    ;;
+esac
+
 AC_CHECK_FUNCS(getrusage times)
 case "$canonical_host_type" in
   *-*-cygwin*)