diff configure.in @ 1500:9300d1a832f0

[project @ 1995-10-03 00:23:22 by jwe]
author jwe
date Tue, 03 Oct 1995 00:23:36 +0000
parents f8d8b6aa31aa
children d508e2cab748
line wrap: on
line diff
--- a/configure.in	Mon Oct 02 10:10:44 1995 +0000
+++ b/configure.in	Tue Oct 03 00:23:36 1995 +0000
@@ -20,7 +20,7 @@
 ### along with Octave; see the file COPYING.  If not, write to the Free
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA  02111-1307, USA.
 
-AC_REVISION($Revision: 1.140 $)
+AC_REVISION($Revision: 1.141 $)
 AC_PREREQ(2.0)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -754,7 +754,15 @@
 AC_PROG_INSTALL
 
 AC_CHECK_PROG(GNUPLOT_BINARY, gnuplot, gnuplot, [])
-if test -z "$GNUPLOT_BINARY"; then
+if test -n "$GNUPLOT_BINARY"; then
+  AC_MSG_CHECKING([to see if your gnuplot supports multiplot])
+  if test -z "`echo 'set multiplot' | gnuplot 2>&1`"; then
+    AC_MSG_RESULT([yes])
+    AC_DEFINE(GNUPLOT_HAS_MULTIPLOT, 1)
+  else
+    AC_MSG_RESULT([no])
+  fi
+else
   AC_MSG_WARN([I didn't find gnuplot.  It isn't necessary to have gnuplot])
   AC_MSG_WARN([installed, but you won't be able to use any of Octave's])
   AC_MSG_WARN([plotting commands without it.])