diff configure.in @ 670:991303b21bae

[project @ 1994-09-07 17:47:52 by jwe]
author jwe
date Wed, 07 Sep 1994 17:47:52 +0000
parents fb4f6556b443
children 93c63deed7aa
line wrap: on
line diff
--- a/configure.in	Wed Sep 07 16:00:59 1994 +0000
+++ b/configure.in	Wed Sep 07 17:47:52 1994 +0000
@@ -21,7 +21,7 @@
 dnl along with Octave; see the file COPYING.  If not, write to the Free
 dnl Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA.
 dnl
-AC_REVISION($Revision: 1.40 $)dnl
+AC_REVISION($Revision: 1.41 $)dnl
 AC_PREREQ(1.8)dnl
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -669,6 +669,26 @@
 dnl Maybe add -Wall to compiler flags now that we're done feature
 dnl testing. 
 dnl
+dnl To get gcc and g++ to be really picky, try these adding these
+dnl options to CFLAGS and CXXFLAGS along with -Wall:
+dnl
+dnl   -ansi
+dnl   -pedantic
+dnl   -Wwrite-strings
+dnl   -Wid-clash-31
+dnl   -Wpointer-arith
+dnl   -Wcast-qual
+dnl   -Wenum-clash
+dnl   -Wcast-align
+dnl   -Wtraditional
+dnl   -Wstrict-prototypes
+dnl   -Wmissing-prototypes
+dnl   -Wnested-externs
+dnl   -Woverloaded-virtual
+dnl   -Winline
+dnl   -felide-constructors
+dnl   -fnonnull-objects
+dnl
 if $ADD_CXX_WALL; then
   CXXFLAGS="$CXXFLAGS -Wall"
   AC_VERBOSE([adding -Wall to CXXFLAGS])