diff configure.in @ 8998:a48fba01e4ac

optimize isnan/isinf/isfinite mappers
author Jaroslav Hajek <highegg@gmail.com>
date Thu, 19 Mar 2009 17:46:38 +0100
parents 6994961bf1f4
children 56018fcd28b0
line wrap: on
line diff
--- a/configure.in	Thu Mar 19 08:54:56 2009 +0100
+++ b/configure.in	Thu Mar 19 17:46:38 2009 +0100
@@ -1776,6 +1776,12 @@
      [Define if your system has a single-arg prototype for gettimeofday.])])
 fi
 
+dnl Maybe <cmath> defines the IEEE functions we need.
+
+OCTAVE_CMATH_FUNC(isnan)
+OCTAVE_CMATH_FUNC(isinf)
+OCTAVE_CMATH_FUNC(isfinite)
+
 dnl Would like to get rid of this cruft, and just have
 dnl
 dnl   AC_CHECK_FUNCS(finite isnan isinf)