diff configure.ac @ 17946:a4bc3ad4c703

Use gnulib uname * configure.ac: remove check for uname and sys/utsname.h. * liboctave/system/oct-uname.cc (octave_uname::init): remove #ifdef HAVE_SYS_UTSNAME_H from uname function. * bootstrap.conf: add uname to gnulib_modules.
author John Donoghue <john.donoghue@ieee.org>
date Sun, 17 Nov 2013 21:31:49 -0500
parents 87db35b69cfd
children abe592ef40b5
line wrap: on
line diff
--- a/configure.ac	Thu Nov 14 22:31:43 2013 +0530
+++ b/configure.ac	Sun Nov 17 21:31:49 2013 -0500
@@ -2024,7 +2024,7 @@
 AC_CHECK_HEADERS([grp.h ieeefp.h inttypes.h locale.h memory.h ncurses.h])
 AC_CHECK_HEADERS([poll.h pthread.h pwd.h sunmath.h sys/ioctl.h])
 AC_CHECK_HEADERS([sys/param.h sys/poll.h sys/resource.h])
-AC_CHECK_HEADERS([sys/select.h sys/utsname.h termcap.h])
+AC_CHECK_HEADERS([sys/select.h termcap.h])
 
 ## C++ headers
 
@@ -2145,7 +2145,7 @@
 AC_CHECK_FUNCS([realpath resolvepath roundl])
 AC_CHECK_FUNCS([select setgrent setpwent siglongjmp strsignal])
 AC_CHECK_FUNCS([tempnam tgammaf toascii])
-AC_CHECK_FUNCS([umask uname waitpid])
+AC_CHECK_FUNCS([umask waitpid])
 AC_CHECK_FUNCS([_kbhit])
 
 dnl There are no workarounds in the code for missing these functions.