diff configure.ac @ 9892:ac69e6f4b33d

Add HDF5-1.8 compatibility while maintaining compatibility with HDF5-1.6 versions
author Kacper Kowalik <xarthisius.kk@gmail.com>
date Tue, 01 Dec 2009 00:49:07 +0100
parents 9ed5f64e3959
children 8d20fb66a0dc
line wrap: on
line diff
--- a/configure.ac	Mon Nov 30 14:32:10 2009 -0500
+++ b/configure.ac	Tue Dec 01 00:49:07 2009 +0100
@@ -631,16 +631,15 @@
   [HDF5 library not found.  Octave will not be able to save or load HDF5 data files.],
   [hdf5.h], [H5Gget_num_objs], [], [],
   [warn_hdf5=
-   OCTAVE_HDF5_HAS_REQUIRED_API
-   if test $octave_hdf5_ok = yes; then
-     TEXINFO_HDF5="@set HAVE_HDF5"
-     AC_DEFINE(HAVE_HDF5, 1, [Define if HDF5 is available.])
-     case "$canonical_host_type" in
-       *-*-msdosmsvc)
-	 OCTAVE_HDF5_DLL
-	 ;;
-     esac
-   fi])
+   OCTAVE_HDF5_HAS_ENFORCED_16_API
+   TEXINFO_HDF5="@set HAVE_HDF5"
+   AC_DEFINE(HAVE_HDF5, 1, [Define if HDF5 is available and newer than version 1.6.])
+   case "$canonical_host_type" in
+     *-*-msdosmsvc)
+       OCTAVE_HDF5_DLL
+       ;;
+   esac
+   ])
 CPPFLAGS="$save_CPPFLAGS"
 LIBS="$save_LIBS"