diff configure.in @ 3034:ad0e94b6784c

[project @ 1997-06-05 21:25:53 by jwe]
author jwe
date Thu, 05 Jun 1997 21:29:47 +0000
parents 9ce32027e269
children b8c5ded2751f
line wrap: on
line diff
--- a/configure.in	Thu Jun 05 16:50:06 1997 +0000
+++ b/configure.in	Thu Jun 05 21:29:47 1997 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.273 $)
+AC_REVISION($Revision: 1.274 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -537,6 +537,15 @@
    else WITH_SHL=maybe; fi],
   WITH_SHL=maybe)
 
+### Enable creation of static libraries.
+
+AC_ARG_ENABLE(static,
+  [  --enable-static         create static libraries],
+  [if test "$enableval" = no; then STATIC_LIBS=false;
+   else STATIC_LIBS=true; fi],
+  STATIC_LIBS=true)
+AC_SUBST(STATIC_LIBS)
+
 ### Enable creation of shared libraries.  Currently only works with
 ### gcc on some systems.
 
@@ -547,6 +556,12 @@
   SHARED_LIBS=false)
 AC_SUBST(SHARED_LIBS)
 
+if $STATIC_LIBS || $SHARED_LIBS; then
+  true
+else
+  AC_MSG_ERROR([You can't disable building static AND shared libraries!])
+fi
+
 use_rpath=true
 AC_ARG_ENABLE(rpath,
   [  --enable-rpath          add -rpath to link command for shared libraries],
@@ -1226,8 +1241,11 @@
   gnuplot:              $GNUPLOT_BINARY
 
   Do internal array bounds checking:       $BOUNDS_CHECKING
+  Build static libraries:                  $STATIC_LIBS
   Build shared libraries:                  $SHARED_LIBS
   Minimal kernel option:                   $OCTAVE_LITE
   Dynamic Linking (dlopen/dlsym):          $WITH_DL
   Dynamic Linking (shl_load/shl_findsym):  $WITH_SHL
+  Include support for GNU readline:        $USE_READLINE
+  Include support for the GNU Info reader: $USE_GNU_INFO
 ])