diff configure.in @ 8770:af676d09da08

Fix test for X11 if "--without-x" is given.
author Thomas Treichl <Thomas.Treichl@gmx.net>
date Tue, 17 Feb 2009 00:27:30 -0500
parents 0899370cce9f
children d3382daaf4d2
line wrap: on
line diff
--- a/configure.in	Tue Feb 17 00:01:33 2009 -0500
+++ b/configure.in	Tue Feb 17 00:27:30 2009 -0500
@@ -264,10 +264,17 @@
 if test "$have_x"; then
   AC_DEFINE(HAVE_X_WINDOWS, 1, [Define if you have X11])
 
-  X11_INCFLAGS="$x_includes"
+  if test $x_includes != "NONE"; then
+    X11_INCFLAGS="$x_includes"
+  fi
   AC_SUBST(X11_INCFLAGS)
 
-  AC_CHECK_LIB(X11, XrmInitialize, [X11_LIBS=-lX11], [X11_LIBS=])
+  if test -z $x_libraries; then
+    AC_CHECK_LIB(X11, XrmInitialize, [X11_LIBS=-lX11], [X11_LIBS=])
+  elif test $x_libraries != "NONE"; then
+    AC_CHECK_LIB(X11, XrmInitialize, 
+      [X11_LIBS="-L$x_libraries -lX11"], [X11_LIBS=], "-L$x_libraries")
+  fi
   AC_SUBST(X11_LIBS)
 fi