diff configure.in @ 3687:b5a285d1c1f4

[project @ 2000-06-29 21:33:00 by jwe]
author jwe
date Thu, 29 Jun 2000 21:33:01 +0000
parents e0b46234555e
children 8aea513ff224
line wrap: on
line diff
--- a/configure.in	Thu Jun 29 16:30:45 2000 +0000
+++ b/configure.in	Thu Jun 29 21:33:01 2000 +0000
@@ -21,7 +21,7 @@
 ### Software Foundation, 59 Temple Place - Suite 330, Boston, MA
 ### 02111-1307, USA. 
 
-AC_REVISION($Revision: 1.327 $)
+AC_REVISION($Revision: 1.328 $)
 AC_PREREQ(2.9)
 AC_INIT(src/octave.cc)
 AC_CONFIG_HEADER(config.h)
@@ -320,6 +320,18 @@
   ;;
 esac
 
+# ----------------------------------------------------------------------
+# Check for HDF5 library
+AC_ARG_WITH(hdf5, [  --without-hdf5          don't use HDF5 output], ok=$withval, ok=yes)
+if test "$ok" = "yes"; then
+	AC_CHECK_LIB(z, deflate)
+	AC_CHECK_LIB(hdf5, H5Pcreate, [
+		AC_CHECK_HEADERS(hdf5.h, [LIBS="-lhdf5 $LIBS"
+			                  AC_DEFINE(HAVE_HDF5)])])
+fi
+
+# ----------------------------------------------------------------------
+
 ### We need these before trying to find libf2c.
 
 OCTAVE_PROG_AR