diff configure.ac @ 16244:b74c4e967f76

gui: remove binary language files from repo and generate them during build * configure.ac: check for lrelease * libgui/Makefile.am: new rule for generating qm-files from ts-files * libgui/languages/*.qm: removed binary language files
author Torsten <ttl@justmail.de>
date Sun, 10 Mar 2013 20:31:16 +0100
parents cf6788da4152
children 98d8d1f4b7f8
line wrap: on
line diff
--- a/configure.ac	Sun Mar 10 09:11:44 2013 -0700
+++ b/configure.ac	Sun Mar 10 20:31:16 2013 +0100
@@ -2587,11 +2587,12 @@
     AC_CHECK_PROGS(MOC, [moc-qt5 moc-qt4 moc])
     AC_CHECK_PROGS(UIC, [uic-qt5 uic-qt4 uic])
     AC_CHECK_PROGS(RCC, [rcc])
-    if test -n "$MOC" && test -n "$UIC" && test -n "$RCC"; then
+    AC_CHECK_PROGS(LRELEASE, [lrelease])
+    if test -n "$MOC" && test -n "$UIC" && test -n "$RCC" && test -n "$LRELEASE"; then
       AC_DEFINE(HAVE_QT, 1, 
-        [Define to 1 if Qt is available (libraries, developer header files, utility programs (moc, uic, and rcc))])
+        [Define to 1 if Qt is available (libraries, developer header files, utility programs (moc, uic, rcc, and lrelease))])
     else
-      AC_MSG_WARN([Qt utility programs moc, uic, and rcc not found -- disabling GUI])
+      AC_MSG_WARN([Qt utility programs moc, uic, rcc, and lrelease not found -- disabling GUI])
       build_gui=no
     fi
   fi