diff configure.ac @ 17111:bb713af2e1d9

build: detect Qt functions required for building the gui * m4/acinclude.m4 (OCTAVE_CHECK_FUNC_QABSTRACTITEMMODEL_BEGINRESETMODEL): New macro to detect Qt functions QAbstractItemModel::beginResetModel and QAbstractItemModel::endResetModel. * configure.ac: Call it and disable the gui if the functions are not found.
author Mike Miller <mtmiller@ieee.org>
date Tue, 30 Jul 2013 00:49:37 -0400
parents 054905bfc306
children 36fd98b9ce48
line wrap: on
line diff
--- a/configure.ac	Tue Jul 30 00:03:00 2013 +0100
+++ b/configure.ac	Tue Jul 30 00:49:37 2013 -0400
@@ -2619,6 +2619,14 @@
   fi
 
   if test $build_gui = yes; then
+    OCTAVE_CHECK_FUNC_QABSTRACTITEMMODEL_BEGINRESETMODEL
+    if test $octave_cv_func_qabstractitemmodel_beginresetmodel = no; then
+      AC_MSG_WARN([QAbstractItemModel::beginResetModel() not found -- disabling GUI])
+      build_gui=no
+    fi
+  fi
+
+  if test $build_gui = yes; then
     OCTAVE_CHECK_FUNC_SETPLACEHOLDERTEXT
   fi