diff configure.in @ 8635:bef8f001032f

Further improvements for OCTAVE_HAVE_FRAMEWORK and the test for the MacOSX Carbon framework.
author Thomas Treichl <Thomas.Treichl@gmx.net>
date Thu, 29 Jan 2009 22:01:49 +0100
parents 53fb843ca498
children 2264092e9f39
line wrap: on
line diff
--- a/configure.in	Thu Jan 29 14:52:38 2009 -0500
+++ b/configure.in	Thu Jan 29 22:01:49 2009 +0100
@@ -272,11 +272,11 @@
 
 ### On MacOSX system the Carbon framework is used to determine ScreenSize
 OCTAVE_HAVE_FRAMEWORK(Carbon, [#include <Carbon/Carbon.h>], [CGMainDisplayID ()],
-  [have_carbon="yes"], [have_carbon="no"])
-if test $have_carbon = "yes"; then
+  [have_framework_carbon="yes"], [have_framework_carbon="no"])
+if test $have_framework_carbon = "yes"; then
   AC_DEFINE(HAVE_FRAMEWORK_CARBON, 1, [Define if framework CARBON is available.])
-  LDFLAGS="$LDFLAGS -Wl,-framework -Wl,Carbon"
-  AC_MSG_NOTICE([adding -Wl,-framework -Wl,Carbon to LDFLAGS])
+  LIBS="$LIBS -Wl,-framework -Wl,Carbon"
+  AC_MSG_NOTICE([adding -Wl,-framework -Wl,Carbon to LIBS])
 fi
 
 ### On Intel systems with gcc, we may need to compile with -mieee-fp