diff configure.ac @ 10858:bf000a56a985

configure.ac: Change warning messages about freetype and fontconfig to reflect their requirement for native graphics. Bug #30594.
author Rik <octave@nomad.inbox5.com>
date Thu, 05 Aug 2010 11:01:52 -0700
parents c0ffe159ba1a
children 97b8d462ef11
line wrap: on
line diff
--- a/configure.ac	Thu Aug 05 20:53:24 2010 +0300
+++ b/configure.ac	Thu Aug 05 11:01:52 2010 -0700
@@ -815,7 +815,7 @@
 
 # ---------------------------------------------------------------------
 
-## libraries needed for graphics
+## libraries needed for native graphics renderer
 
 warn_freetype=""
 
@@ -830,7 +830,7 @@
 
   AC_CHECK_FT2([9.0.3], [AC_DEFINE(HAVE_FREETYPE, 1, [Define to 1 if you have Freetype library.])
     XTRA_CXXFLAGS="$XTRA_CXXFLAGS $FT2_CFLAGS"],
-    [warn_freetype="FreeType library not found.  Native renderer will not have on-screen text"])
+    [warn_freetype="FreeType library not found.  Native graphics will be disabled."])
 
   ## fontconfig library
 
@@ -842,7 +842,7 @@
       XTRA_CXXFLAGS="$XTRA_CXXFLAGS $FONTCONFIG_CFLAGS"
       AC_DEFINE(HAVE_FONTCONFIG, 1, [Define to 1 if fontconfig is present])], [
       have_fontconfig=no
-      warn_fontconfig="Fontconfig not found.  Native text rendering will use hard-coded font instead."])
+      warn_fontconfig="Fontconfig library not found.  Native graphics will be disabled."])
   fi
 
   ## fltk (www.fltk.org)