diff test/Makefile.am @ 18328:c3f3fa5a5db5

build: Add rule to check with jit compiler enabled * configure.ac: Add conditional for HAVE_LLVM * test/Makefile.am: Add check-jit target * Makefile.am: Add check-jit target
author Stefan Mahr <dac922@gmx.de>
date Mon, 04 Nov 2013 00:04:55 +0100
parents 93b3d03b05e7
children 0e1f5a750d00
line wrap: on
line diff
--- a/test/Makefile.am	Mon Jan 06 14:00:43 2014 +0100
+++ b/test/Makefile.am	Mon Nov 04 00:04:55 2013 +0100
@@ -71,6 +71,11 @@
 check: sparse.tst bc-overload-tests.stamp
 	$(top_builddir)/run-octave $(RUN_OCTAVE_OPTIONS) --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)
 
+if AMCOND_HAVE_LLVM
+check-jit: sparse.tst bc-overload-tests.stamp
+	$(top_builddir)/run-octave $(RUN_OCTAVE_OPTIONS) --jit-compiler --norc --silent --no-history $(srcdir)/fntests.m $(srcdir)
+endif
+
 sparse.tst: build-sparse-tests.sh
 	$(srcdir)/build-sparse-tests.sh