diff configure.in @ 6286:c6a7b0453f9a

[project @ 2007-02-08 19:04:38 by jwe]
author jwe
date Thu, 08 Feb 2007 19:04:38 +0000
parents d26c558691cd
children e8c4edcfe43d
line wrap: on
line diff
--- a/configure.in	Thu Feb 08 09:50:11 2007 +0000
+++ b/configure.in	Thu Feb 08 19:04:38 2007 +0000
@@ -29,7 +29,7 @@
 EXTERN_CXXFLAGS="$CXXFLAGS"
 
 AC_INIT
-AC_REVISION($Revision: 1.553 $)
+AC_REVISION($Revision: 1.554 $)
 AC_PREREQ(2.57)
 AC_CONFIG_SRCDIR([src/octave.cc])
 AC_CONFIG_HEADER(config.h)
@@ -1531,7 +1531,9 @@
   fi
 
   ## autoconf test for LoadLibrary appears broken. Bypass for cygwin/mingw 
-  if !($dlopen_api || $shl_load_api || $loadlibrary_api || $dyld_api); then
+  if $dlopen_api || $shl_load_api || $loadlibrary_api || $dyld_api; then
+    true
+  else
     case "$canonical_host_type" in
       *-*-cygwin* | *-*-mingw* | *-*-msdosmsvc)
        loadlibrary_api=true;